Search
FM Scout is the only community you can talk Football Manager in real time. Here are 10 reasons to join!

Version not supported

cannot load fm scout after my last download
Started on 4 March 2019 by CutKiller79
Latest Reply on 13 March 2019 by Smoothstud
  • POSTS8
  • VIEWS4008
  • FOLLOWERS1
 
I still get this message coming up....i have no clue if it can be fixed or do i have to keep downloading Genie Scout and hope that a new version has been updated?
1

You are reading "Version not supported".

FMS Chat

Stam
hey, just wanted to let you know that we have a fb style chat for our members. login or sign up to start chatting.