Search
FM Scout is the only community you can talk Football Manager in real time. Here are 10 reasons to join!

Genie Scout not working with version 18.3

Started on 4 March 2018 by jacomus / First Post
Latest Reply on 18 March 2018 by Justice / Last Post
 
Hi. Does anyone know how I can use Genie Scout with 18.3? I receive an error message saying that my version is not compatible.

Thank you.
i have the same problem
+1
FM's current version is 18.3.2, while Genie Scout's public (free) version is not. The public version of Genie Scout, which will be compatible with the current version of FM, will be released some time during the start of April.

You are reading "Genie Scout not working with version 18.3".

FMS Chat

Stam
hey, just wanted to let you know that we have a fb style chat for our members. login or sign up to start chatting.