Search
FM Scout is the only community you can talk Football Manager in real time. Here are 10 reasons to join!

First time using Genie Scout

get a pop up saying the 20.3 version im using isnt compatible with the genie version
Started on 24 February 2020 by sootyaba
Latest Reply on 24 February 2020 by sootyaba
  • POSTS1
  • VIEWS258
 
Hi iv just downloaded the scout genie but im unable to use it as it says the 20.3 version im using isnt compatible

You are reading "First time using Genie Scout".

FMS Chat

Stam
hey, just wanted to let you know that we have a fb style chat for our members. login or sign up to start chatting.