Search
On FM Scout you can chat about Football Manager in real time since 2011. Here are 10 reasons to join!

I need 4.0 version

Doesnt work
Started on 21 August 2021 by Oscarr31234
Latest Reply on 14 September 2021 by dzoni76
  • POSTS3
  • VIEWS547
 
Hello everyone, i want to download fmse but my game version 4.0 and i cant use this version so i need 4.0 version...
Hi Oscar,
Newer versions are backwards compatible with whatever game version that FMSE 4.0.0 supported, so I don't see how that would make any difference to you.
Hello, tell me why I can not install fmse on windows 10....

You are reading "I need 4.0 version".

FMS Chat

Stam
hey, just wanted to let you know that we have a fb style chat for our members. login or sign up to start chatting.